ESX 3.5 – Keyboard Issues displaying wrong characters

Posted on Updated on

I ran into an issue getting an ESX 3.5 server to join a Virtual Center 2.5 server today..

For some reason I couldn’t get it to join my VC server and when I tried to I would get the error bad password or user name. Connecting the VI client straight to the server failed, trying to use the web interface failed, but I could remote into the server via an IP KVM and log on without issue.

What I found was my keyboard map on this individual server was set to UK and not US.

Here is how I resolved this issue.

Logged in to the host as root

cd /etc/sysconfig
vi keyboard
Press esc twice
Press insert to edit
Changed KEYTABLE=”uk″ to KEYTABLE=”us″
Press esc twice
Enter :qw > to save the file and exit
Reboot the ESX server
And now it works like a champ..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s